403 from Comicvine all of a sudden

Post any problems / bugs / issues that are Mylar-related in here.
Post Reply
byronbulb
Posts: 14
Joined: Sat Jul 09, 2016 2:36 pm

403 from Comicvine all of a sudden

Post by byronbulb »

This is really weird, all of a sudden a day or two ago Comicvine stopped responding, and I get a 403: forbidden when I try to access it via mylar, and even when I try to access it via a browser. I've checked, and it hasn't been reported as having any downtime. When I try it via another ISP, say my cellular internet, I can load the site fine. Did I get banned somehow? Has this happened to any other Mylar users?
diesel
Posts: 4
Joined: Fri Feb 03, 2023 2:10 am

Re: 403 from Comicvine all of a sudden

Post by diesel »

byronbulb wrote: Thu Aug 24, 2023 9:11 pm This is really weird, all of a sudden a day or two ago Comicvine stopped responding, and I get a 403: forbidden when I try to access it via mylar, and even when I try to access it via a browser. I've checked, and it hasn't been reported as having any downtime. When I try it via another ISP, say my cellular internet, I can load the site fine. Did I get banned somehow? Has this happened to any other Mylar users?
There has be a bunch of changes to CV in the past few days that need to get figured out. But getting a 403 from a browser does lean towards them banning you at an IP / ISP level.
[email protected]
Posts: 2
Joined: Thu Feb 29, 2024 9:20 pm

Re: 403 from Comicvine all of a sudden

Post by [email protected] »

I am noticing this as well. I keep getting the 403 access denied. It looks like they are rate limiting. Does anyone know how to set Mylar to only do a certain number of API calls to comicvine per hour?
ChapeL
Posts: 2
Joined: Fri Mar 01, 2024 1:06 pm

Re: 403 from Comicvine all of a sudden

Post by ChapeL »

Same here, looks like a temporary ban on my IP address, I can't even access their website for a while and then it just starts working after 30 min and goes down again.
User avatar
evilhero
Site Admin
Posts: 2888
Joined: Sat Apr 20, 2013 3:43 pm
Contact:

Re: 403 from Comicvine all of a sudden

Post by evilhero »

ATM, it looks like changing the cv_user_agent string in the config.ini (with mylar not running), will help things as long as you put it to a somewhat recent user agent string (works for some, doesn't for others).

You can go here in a browser and it will tell you what your current browser agent is.

To keep things identical (there's been some apparent issues when you're browsing the CV site as well) between your browser and mylar, change the cv_user_agent string to whatever it shows in the website.

ATM, the built-in CT uses a random user-agent which would conflict with whatever is in the cv_user_agent field, so the next Master release (v0.7.9) will automatically set the the CT user-agent to be identical to what Mylar is set to use.
ChapeL
Posts: 2
Joined: Fri Mar 01, 2024 1:06 pm

Re: 403 from Comicvine all of a sudden

Post by ChapeL »

Thank you :) Looks like this solved it!

For reference, I changed from:
Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/42.0.2311.135 Safari/537.36 Edge/12.246

To:
Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/122.0.0.0 Safari/537.36 Edg/122.0.0.0
[email protected]
Posts: 2
Joined: Thu Feb 29, 2024 9:20 pm

Re: 403 from Comicvine all of a sudden

Post by [email protected] »

This seems to be working for me as well! Thanks for the quick response here
Post Reply