Post Processing - Files not being moved (updated)

Post any problems / bugs / issues that are Mylar-related in here.
zeus163
Posts: 15
Joined: Mon Feb 01, 2021 5:18 am

Re: Post Processing - Files not being moved (updated)

Post by zeus163 »

Just a quick note to say thanks for the naming tips. Now that I know what is going on, I can simply rename the files going forward. I think that is easy enough.

Slowly but surely I'll start to get my collection moved into Mylar.

I'm thinking this is a probably not, but is there a way to sort comics by publisher in the folders? So, if it is Marvel comic, the comics end up under Marvel\comic name? I couldn't see a way to do that, but was just curious.

In any case, thanks for all your responses and help. I really appreciate it. You've given me a bit of new life and I can have Mylar grab my issues for me. Plus, it's already started to grab this weeks releases!

Super duper!
leaderdog
Posts: 373
Joined: Sun Apr 26, 2015 1:52 pm

Re: Post Processing - Files not being moved (updated)

Post by leaderdog »

If you put go to:
Settings -> Advanced Settings

under Folder format:
I use:

Code: Select all

$Publisher\$Series $Type ($Year)
This will start the comic with either Marvel, DC, etc
example: Marvel\Wolverine (1988)

I had to change the order of the way I liked having my comics so Mylar would work. A small sacrifice for the convenience of the software. ;)

hmm, I don't think $Type works. so maybe don't use that. I just noticed nothing shows as GN or TPB. Maybe I should remove that now too.

Incidentally under File Format:
It took some doing but this is what finally worked well for naming:

Code: Select all

$Series $Annual $VolumeN - $Issue - ($Year)
Everyone likes their own naming format, that's why it's challenging to get Mylar to download some files.

Have fun
zeus163
Posts: 15
Joined: Mon Feb 01, 2021 5:18 am

Re: Post Processing - Files not being moved (updated)

Post by zeus163 »

Hey!

Thanks a bunch. I have now set mine to $Publisher\$Series ($Year). I had at one point, tried to put volume there, but I always got (). So, I stopped that after a few and decided I'd just try and remember if a series is a different volume.

Yes, it is a small sacrifice, but it is such a convenience to set it and let it go. I'm still just in the tweaking and setting up all my comics stage, but better to start now than later.

I've left the File Format the same for now. I've had to rename a few TPB/GN's, but that's been OK.

Once again, thanks! Now I'll have to spend some time after work in the next days and get the folders by publisher now. Not a big deal whatsoever!
User avatar
evilhero
Site Admin
Posts: 2712
Joined: Sat Apr 20, 2013 3:43 pm
Contact:

Re: Post Processing - Files not being moved (updated)

Post by evilhero »

Thanks leaderdog for chiming in!

Just to add to what he mentioned:
  • on the Configuration tab, beside the Folder Format option there's a small 'i' icon - holding your mouse over that will display a list of available variables that you can reference in your format string (there's also one for File Format, as there are small differences)
  • for Volume to work, you need to specify either $VolumeN or $VolumeY. The N is the numeric volume, the Y means use the series year as the volume (everybody has their own preference).
  • if you want to use the $Type string in your format - you need to enable a config.ini option for it to apply properly. With Mylar not running, In the config.ini, change the format_booktype value to True. It won't alter any previous existing directories, but it will change new ones going forward.
I keep on forgetting to remove the ini only option for the $Type string - at some point the default value will be set to True so this won't be an issue, however atm it's a manual type of ini change.

Hope that helps abit more!
zeus163
Posts: 15
Joined: Mon Feb 01, 2021 5:18 am

Re: Post Processing - Files not being moved (updated)

Post by zeus163 »

I should probably create a new thread for this, but just thought I'd drop it here first since you have been so awesome in helping me out.

I did enable the $Type string for naming comics. I'm glad I did. Mylar and comics is a well oiled machine.

However, I see that there is an update and when I try to check for upgrades within Mylar, nothing happens and the log file shows this:
WARNING [ERROR] Could not get the latest commit from github: 'sha'

So, I must have done something when I originally installed it. I'm not sure the github command I need to call to upgrade. .Or do I need to follow the "Upgrading from evilhero/mylar" instructions from the GitHub page making sure to save and then copy over my config.ini, mylar.db, and cache directory before running the install command?

Sorry for my dumb question. If I need to start a new thread, I will, it just seems that I've been putting all my questions in here, so I decided to continue here.

Thanks again!!!
Post Reply