Post-processing fails

Post any problems / bugs / issues that are Mylar-related in here.
Post Reply
slim2169
Posts: 6
Joined: Wed Sep 09, 2020 7:08 pm

Post-processing fails

Post by slim2169 »

Hi everyone,
I recently setup Mylar in a docker on my Unraid server. It's sending downloads to sabnzbd as it should, and I have post processing enabled, but the log states it can't find the file in the location that sabnzbd is specifying. I'm using Completed Download Handling, and it's the only post-processing enabled. I'm not using scripts or monitored folders. I'm using the same container paths on both sabnzbd and Mylar, and these paths work fine for Sonarr and Radarr. I've also checked permissions and it appears everything is correct. The log file is shown below and also the rest of the info on my setup.

Code: Select all

09-Sep-2020 13:31:36 - INFO    :: mylar.historycheck.126 : AUTO-COMPLETE-NZB : found matching completed item in history. Job has a status of Completed
09-Sep-2020 13:31:36 - INFO    :: mylar.historycheck.144 : AUTO-COMPLETE-NZB : no file found where it should be @ /Downloads/Complete/Comics/The.Walking.Dead.013 - is there another script that moves things after completion ?
09-Sep-2020 13:31:36 - WARNING :: mylar.nzb_monitor.3201 : AUTO-COMPLETE-NZB : Unable to complete post-processing call due to not finding file in the location provided. [{'status': True, 'nzo_id': 'SABnzbd_nzo_556dhwo6', 'queue': {'mode': 'queue', 'search': 'SABnzbd_nzo_556dhwo6', 'output': 'json', 'apikey': '34d311073bdeb5d954855af355b37df9'}, 'comicid': '18166', 'issueid': '106785', 'apicall': True}]
Running Unraid 6.8.3 with hotio's mylar3 docker. Mylar Version: master [v0.4.3 - Oh my stars and garters!]
-- source (build 3af6bb19fec0d2426d076ae574a3523a7a12ad6e)

Thanks!
User avatar
evilhero
Site Admin
Posts: 2587
Joined: Sat Apr 20, 2013 3:43 pm
Contact:

Re: Post-processing fails

Post by evilhero »

Please update to the latest version if you can (not sure when the image updates on that side - newest is v0.4.4).

Turn on verbose/debug logging - go into History, View Logs, then click on the Toggle Verbose Logging ON option. You'll see something appear in the logs indicating that verbose logging is now enabled.

Now go back to one of the given issues, and try to download something again via the magnifying glass (don't use the retry option just in case it's something funky with that aspect, let's try and get a clean log). If it doesn't complete again and throws the same Warning as in your previous output, then we need to get that log.

To do that, the easy way - is to go to the Configuration, and click on the CarePackage button in the upper right. It will create a zip file that holds your cleaned config.ini and log files (so no apikeys, etc are included), as well as the mylar.db. It should download in your browser and then you can just link it to us or email me the carepackage.zip file. If you happen to miss the download option for w/e reason, it's stored in the cache folder of the mylar root (usually mylar/cache for most systems).

Once we get the carepackage, we can look at why it's not working properly.
slim2169
Posts: 6
Joined: Wed Sep 09, 2020 7:08 pm

Re: Post-processing fails

Post by slim2169 »

Actually, I finally just now figured it out. For some reason the owner and group of the Downloads directory was root root, whereas the others were hotio user. I saw another post with a similar issue. Changed the ownership and now it's all working. I appreciate the response!
slim2169
Posts: 6
Joined: Wed Sep 09, 2020 7:08 pm

Re: Post-processing fails

Post by slim2169 »

All right, I lied, this isn't working correctly still. I did get post-processing working for a bit, but it was still failing the majority of the time. Then permissions on the /Downloads folder changed back to root:root. Also, meta tagging was failing as well, saying it wasn't a valid rar file, but I had Mylar converting them to cbz during post-processing, so it shouldn't be a rar file anymore. I ended up reinstalling the container and updating to the latest version as recommended, but none of the post-processing is working now. Here's the care package file, thanks for any help you can provide! https://www.dropbox.com/s/vx40l29c4iawl ... e.zip?dl=0.

I also checked permissions inside the container and changed the Downloads directory to match the Comics directory:

Code: Select all

bash-5.0# ls -ld /Downloads
drwxrwxrwx    1 root     root            16 Sep 12 19:44 /Downloads
bash-5.0# ls -ld /Comics
drwxrwxrwx    1 root     root            44 Sep 12 17:18 /Comics
slim2169
Posts: 6
Joined: Wed Sep 09, 2020 7:08 pm

Re: Post-processing fails

Post by slim2169 »

Ok, update here. Apparently during one of my reinstalls I fudged the path for the Downloads folder. That's correct now and Mylar does see the downloaded files. But if I have it snatch several files at once, it doesn't always post-process all the files. Some just sit in the download folder, no error in the log, it's like it just missed it. You can see where it snatches Locke & Key: Omega Issue: 3 and issue 4. they both completed, but issue 4 was processed and issue 3 was not. Here's a newer version of the care package with those downloads https://www.dropbox.com/s/ibuzu3fm5dj0j ... 9.zip?dl=0.
slim2169
Posts: 6
Joined: Wed Sep 09, 2020 7:08 pm

Re: Post-processing fails

Post by slim2169 »

Fixed most of the issues I was having, I'm still experiencing the issue where not all downloaded files are post-processed. Did 40 downloads of a series yesterday, only 11 post-processed, I can manually trigger it though and then they all post-process. It's not a huge deal since they still can be processed, but if you want any more logs or anything to troubleshoot it, let me know. Regardless, this is a great piece of software, thank you Evilhero!
User avatar
evilhero
Site Admin
Posts: 2587
Joined: Sat Apr 20, 2013 3:43 pm
Contact:

Re: Post-processing fails

Post by evilhero »

If any of the files had a - in the filename, there was a recent error due to a previous push that caused the parser to just die. Problem is that if you were doing it during a refresh/recheck, it wouldn't update any issues due to dying out (so it would look like it hadn't updated the status of the downloaded ones, when in fact it hadn't updated any of them).

So that was a big glitch that we pushed out a bit early to the master branch today. So if you can, again, update to the newest master depending on your docker (v0.4.5) is the newest as of today, and then try doing it again if you can (or grab something else, w/e).

Only prior to doing that make sure you put Mylar into debug/verbose mode so that we can get the full debug logs. The logs in your last carepackage were all INFO level, which unfortunately leaves out a whole lot that is kind of necessary in order to troubleshoot this kinda thing.

Thanks for the props - and I am not quite so alone in coding Mylar nowadays, so thanks to everyone that's helped get us this far ;)
slim2169
Posts: 6
Joined: Wed Sep 09, 2020 7:08 pm

Re: Post-processing fails

Post by slim2169 »

Downloaded a few series yesterday and today, only two didn't post process yesterday and none so far today, so I think that latest update fixed it. Thanks for the help!
Post Reply