Post-processing with ComicRN failing

Post any problems / bugs / issues that are Mylar-related in here.
User avatar
evilhero
Site Admin
Posts: 2372
Joined: Sat Apr 20, 2013 3:43 pm
Contact:

Re: Post-processing with ComicRN failing

Post by evilhero » Fri Jun 01, 2018 3:56 pm

You can get an older version of autoProcessComics.py from here. You will have to use the username/password combination however instead of the APIkey solution and you'll receive warnings in the logs pertaining to the outdated version.

If you use the newer autoProcessComics.py file, and you don't have requests installed on your OS - it will still work and revert back to the original-type version so things will post-process (albeit with a warning like mentioned above).

The newest autoProcessComics.py file is version 2.04 which includes various changes / improvements that are necessary if you're using the newer method (ie. you'll get errors if you're not running this particular version).

If you run into problems, if you could post the debug logs from Mylar showing the failed post-processing attempt it would help me narrow down/fix any related problems pertaining to this.

Rumik
Posts: 30
Joined: Sat Jul 22, 2017 12:21 pm

Re: Post-processing with ComicRN failing

Post by Rumik » Fri Jun 01, 2018 4:25 pm

Hmm, sounds like everything should be working then!

Fri Jun 1 17:22:56 2018 INFO Executing post-process-script ComicRN.py for Rick.and.Morty.038.2018.digital.dargh-Empire
Fri Jun 1 17:22:56 2018 INFO ComicRN: Requests module not found on system. I'll revert so this will work, but you probably should install
Fri Jun 1 17:22:56 2018 INFO ComicRN: requests to bypass this in the future (ie. pip install requests)
Fri Jun 1 17:22:56 2018 INFO ComicRN: Loading config from /share/Backups/OneDrive/Misc/NZBGetScripts/autoProcessComics.cfg
Fri Jun 1 17:22:56 2018 INFO ComicRN: Opening URL: http://localhost:8090/api?apikey=cde7ad ... e&failed=0
Fri Jun 1 17:22:56 2018 INFO ComicRN: Unable to open URL: <urlopen error [Errno 111] Connection refused>
Fri Jun 1 17:22:56 2018 ERROR Post-process-script ComicRN.py for Rick.and.Morty.038.2018.digital.dargh-Empire failed (terminated with unknown status)
Fri Jun 1 17:22:56 2018 INFO Collection Rick.and.Morty.038.2018.digital.dargh-Empire added to history

Thanks mate!

jedimole
Posts: 108
Joined: Sat Jan 02, 2016 9:19 pm

Re: Post-processing with ComicRN failing

Post by jedimole » Fri Jun 01, 2018 8:01 pm

The location appears to be on your OneDrive. Is it passing the parameters properly?

Rumik
Posts: 30
Joined: Sat Jul 22, 2017 12:21 pm

Re: Post-processing with ComicRN failing

Post by Rumik » Fri Jun 01, 2018 8:09 pm

As far as I know. Everything was working fine, albeit spottily, up until a few weeks ago.

User avatar
evilhero
Site Admin
Posts: 2372
Joined: Sat Apr 20, 2013 3:43 pm
Contact:

Re: Post-processing with ComicRN failing

Post by evilhero » Mon Jun 04, 2018 3:33 pm

According to that snippet - you're still using the newer autoProcessComics.py file which has the apikey requirement (and your autoProcessComics.cfg has the apikey value set as it's shown in the URL it's trying to open). Not sure if you're wanting to use that method or not based on yoru previous question.

If not, make sure you put the autoProcessComics (.py & .cfg) files in the correct location where NZBGet can use them (since they have to be in the scripts location within NZBGet for it to be used).

Otherwise, are nzbget and mylar on the same machine? (ie. dockers would be considered different machines since you can't access the typical localhost as a global across all dockers the same way - I think).

Rumik
Posts: 30
Joined: Sat Jul 22, 2017 12:21 pm

Re: Post-processing with ComicRN failing

Post by Rumik » Mon Jun 04, 2018 3:38 pm

I got the latest version of everything to make it easier to troubleshoot. All the files are in the NZBGet scripts directory- autoProcessComics.cfg, .py and ComicsRN.py are all in there.

User avatar
evilhero
Site Admin
Posts: 2372
Joined: Sat Apr 20, 2013 3:43 pm
Contact:

Re: Post-processing with ComicRN failing

Post by evilhero » Mon Jun 04, 2018 3:45 pm

Are you running dockers for each application or are they on separate machines ? It's saying the SAB server cannot connect to your Mylar instance (saying that Mylar is running on localhost:8090 and it's trying to reach it from the SAB instance)

Rumik
Posts: 30
Joined: Sat Jul 22, 2017 12:21 pm

Re: Post-processing with ComicRN failing

Post by Rumik » Mon Jun 04, 2018 3:53 pm

Both Mylar and NZBGet are on the same QNAP NAS device. Mylar is set to run on localhost with http port 8090. HTTPS is turned off, authentication is set to none.

Appreciate your help with his!

User avatar
evilhero
Site Admin
Posts: 2372
Joined: Sat Apr 20, 2013 3:43 pm
Contact:

Re: Post-processing with ComicRN failing

Post by evilhero » Mon Jun 04, 2018 4:04 pm

Is there anything in the Mylar debug logs when NZBGet attempts to connect to Mylar?

You can also try this - when you snatch something in Mylar and it gets sent to NZBGet, it will show the url it's submitting. You can verify the addurl line in the url itself (it will show in debug logs), and if it's anything other than http://localhost:8090 - you'd need to change your autoProcessComics.cfg to accommodate that.

It sounds like either the address it's using is incorrect (ie. whatever you have your Mylar host set to in the Mylar configuration is what the value should be in autoProcessComics.cfg), and/or possibly the apikey is wrong.

jedimole
Posts: 108
Joined: Sat Jan 02, 2016 9:19 pm

Re: Post-processing with ComicRN failing

Post by jedimole » Mon Jun 04, 2018 4:04 pm

Rumik wrote:
Mon Jun 04, 2018 3:38 pm
I got the latest version of everything to make it easier to troubleshoot. All the files are in the NZBGet scripts directory- autoProcessComics.cfg, .py and ComicsRN.py are all in there.
Do you mean the real location for NZBget, or in the mylar folder scripts directory?

Post Reply