Problem w/Manual Intervention procedure

Post any problems / bugs / issues that are Mylar-related in here.
Post Reply
Tant
Posts: 1
Joined: Sat May 30, 2020 2:34 am

Problem w/Manual Intervention procedure

Post by Tant » Sat May 30, 2020 2:58 am

Hey there,

Mylar Docker image: Linuxserver.io version:- 94dcfd13-ls38 Build-date:- 2020-05-03T11:55:32+00:00 docker image.
Config:
Root Path: /mylar
NGINX proxy redirect from Syno FQDN:443 to docker HTTP standard port 8090.

Spent the past couple days getting used to it and am running into problems with the Manual Intervention feature.
When the import job hits these particular items this is logged and then the import job stops, waiting for action:

Code: Select all

00-May-2020 00:00:00 - ERROR   :: mylar.excepthook.315 : Thread-39 : Uncaught exception: Traceback (most recent call last):
  File "/app/mylar/mylar/logger.py", line 337, in new_run
    old_run(*args, **kwargs)
  File "/usr/lib/python2.7/threading.py", line 754, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/app/mylar/mylar/webserve.py", line 4779, in preSearchit
    self.addbyid(sr['comicid'], calledby=True, imported=imported, ogcname=ogcname, nothread=True)
  File "/app/mylar/mylar/webserve.py", line 439, in addbyid
    return importer.addComictoDB(comicid, mismatch, None, imported, ogcname)
  File "/app/mylar/mylar/importer.py", line 92, in addComictoDB
    checkdirectory = filechecker.validateAndCreateDirectory(comlocation, True)
  File "/app/mylar/mylar/filechecker.py", line 1705, in validateAndCreateDirectory
    if os.path.exists(dir):
  File "/usr/lib/python2.7/genericpath.py", line 26, in exists
    os.stat(path)
TypeError: coercing to Unicode: need string or buffer, NoneType found
Upon clicking the [Select] link:

Code: Select all

https://FQDN/mylar/importresults_popup?SRID=000000&ComicName=COMIC&imported=yes&ogcname=COMICl&DynamicName=COMIC&Volume=None
the page simply refreshes and the below is logged:

Code: Select all

00-May-2020 00:00:01 - WARNING :: mylar.importresults_popup.4790 : CP Server Thread-3 : There are no search results to view for this entry SOME_COMIC. Something is probably wrong.
Eliminating the browser as the issue I've tried different browsers, private/incognito mode w/cache cleared,pop-ups allowed but that doesn't fix the page refresh issue. I presume that some sort of pop-up is supposed to occur where I can select options but that's just not happening.

Any suggestions or quick tweaks I could apply that can get me past this issue?

Recent reading indicates that the docker-based version is not actively being worked since efforts are being put towards the mylar3 project. I do have the option of pulling down the install and working outside of the pre-build docker image but I'm looking for path-of-least-resistance at this point ;)

Appreciate any input/suggestions.

User avatar
evilhero
Site Admin
Posts: 2532
Joined: Sat Apr 20, 2013 3:43 pm
Contact:

Re: Problem w/Manual Intervention procedure

Post by evilhero » Mon Jun 22, 2020 8:39 pm

The initial error is stating that you don't have a Comic Location path set.

Basically it's trying to add the series to your watchlist, but it can't as it can't be found. Unless you're using the option to Set import paths to series location paths, the Comic Location path is a requirement as that's where it will be creating the directory where your issues will go (assuming you selected Move of course).

The popup not showing is an issue that I believe we resolved in Mylar3, but it's probably still lingering around in 2.

Honestly, if you can get onto Mylar3 prior to doing the import - you'll probably safe yourself a lot of issues during the import process. That and at some point, the importer itself is going thru an upgrade process in order to accomodate TPBs/GNs etc, in addition to fixing some of the outstanding importer problems (one being the popup window on manual intervention).

Post Reply