Continuing series not downloading, 404: Client not found errors

Post any problems / bugs / issues that are Mylar-related in here.
bigfire
Posts: 10
Joined: Mon Feb 04, 2019 4:57 pm

Re: Continuing series not downloading, 404: Client not found errors

Post by bigfire » Fri Mar 29, 2019 10:37 pm

Good tip, I'll start using the flag until I've gotten the problem resolved.


User avatar
evilhero
Site Admin
Posts: 2383
Joined: Sat Apr 20, 2013 3:43 pm
Contact:

Re: Continuing series not downloading, 404: Client not found errors

Post by evilhero » Mon Apr 01, 2019 3:35 pm

Well those were debug logs, however none of those log files contained any snatches, so can't trace the qbittorrent problems.

Try turning off your folder monitor, and then perform a manual search for something. Once it fails (cause that's what we're trying to go for here), stop Mylar so the logs stop writing. Paste those logs and we'll get the right lines we need.

Bigfireq
Posts: 17
Joined: Sat May 05, 2018 3:22 am

Re: Continuing series not downloading, 404: Client not found errors

Post by Bigfireq » Tue Apr 02, 2019 3:48 am

Here you go.

https://drive.google.com/open?id=1kaBo1 ... ts6yVYxsoS

I see the torrent in my cache folder when it was originally downloaded on 3/6.

User avatar
evilhero
Site Admin
Posts: 2383
Joined: Sat Apr 20, 2013 3:43 pm
Contact:

Re: Continuing series not downloading, 404: Client not found errors

Post by evilhero » Tue Apr 02, 2019 3:27 pm

You're going to have to try again unfortunately. Same steps as above - the snatch you tried was a previous attempted snatch that got marked as Failed Download, so Mylar won't re-snatch it until the Failed status is removed.

You can however manage your Failed Downloads, by going to the Manage tab / Manage Failed Downloads and then clear any downloads that were marked incorrectly due to your client not being sent the download.

So either clear off a few failed downloads and try a clean snatch for one of those via the magnifying glass icon, or try a completely new item that was attempted previously.

Eventually we'll get the log to have the information we need!

Bigfireq
Posts: 17
Joined: Sat May 05, 2018 3:22 am

Re: Continuing series not downloading, 404: Client not found errors

Post by Bigfireq » Mon Apr 08, 2019 9:08 am

Hi, new logs! https://drive.google.com/open?id=1u2i1b ... GVwcuhovWy

I think a "clean snatch" meant to add a new comic series to the database, but if it means something else, let me know. Since I wasn't sure, I just removed the failed status from two issues and hit the magnifying glass to get them to download again. Looking through the logs I couldn't find an error or even a hint as to it finding them, so I let it go for an hour, but I'm still not seeing an error, so I hope it means something to you! :-)

Let me know if I need to try it again, and if my guess is right about the clean snatch, and I'll give it another try.

Bigfireq
Posts: 17
Joined: Sat May 05, 2018 3:22 am

Re: Continuing series not downloading, 404: Client not found errors

Post by Bigfireq » Fri Apr 12, 2019 7:40 am

I checked Mylar and saw that the Folder Watch was turned on. I don't remember doing that, but maybe I just didn't save it correctly. Anyway, I went ahead and made sure it was turned off, cleared the logs, turned on debug, manually cleared failed links on a couple of comics and manually searched for them. I also added a new comic series as well, so there should be examples of everything in these latest logs. https://drive.google.com/open?id=1v9QpE ... u1qh6U7RkQ

User avatar
evilhero
Site Admin
Posts: 2383
Joined: Sat Apr 20, 2013 3:43 pm
Contact:

Re: Continuing series not downloading, 404: Client not found errors

Post by evilhero » Tue Apr 16, 2019 3:26 pm

It's still saying it sent successfully to your torrent client - do you not see any logging on your client that the webAPI was accessed from the mylar IP ?

Maybe blank out the directory location path in your qBittorent section within Mylar, and try it without that.

Whenever it accesses your qBit client - it will be logged in your qbit client as such. So if it's not logging that part (even after removing the directory location part as above), then for some reason it's still not able to access your client properly.

bigfire
Posts: 10
Joined: Mon Feb 04, 2019 4:57 pm

Re: Continuing series not downloading, 404: Client not found errors

Post by bigfire » Fri Apr 19, 2019 6:10 am

I do see logging saying that the Webapi was accessed (though I don't believe it specifies it came from Mylar).

I've blanked out the directory location, but I haven't seen any difference in behavior or in the logs.

At this point, I'm thinking nuking from orbit is the right approach, because I can't seem to find a smoking gun. I was thinking of switching to Deluge first, to see if it that fixed it, and then blowing away Mylar and reinstalling if that didn't fix it. What I'm concerned about is how I come back from a wipe like that. So here's what I'm thinking about doing:

1) Manually opening the downloaded torrrents that never got passed to Qbittorrent so I can get caught up.
2) Exporting my wanted list.
3) Configure Mylar for Deluge. If the problem is fixed, I should be good.
4) If the problem isn't fixed, blow away Mylar and recreate it, and then do an import of the wanted list.

Bigfireq
Posts: 17
Joined: Sat May 05, 2018 3:22 am

Re: Continuing series not downloading, 404: Client not found errors

Post by Bigfireq » Mon May 13, 2019 7:08 am

FYI, I finally read through everything I could about how to migrate Mylar, and got started on the first step, which was to try it out with Deluge. I set it up, added some new comics, and wham, they showed up, no problem.

I'm pondering going back and wiping out qbittorrent completely and reinstalling it fresh as a test.

Post Reply