Error on Recheck Files

Post any problems / bugs / issues that are Mylar-related in here.
Post Reply
Posts: 8
Joined: Fri Jun 10, 2016 10:07 am

Error on Recheck Files

Post by musictrivianut » Sat Jan 12, 2019 11:19 am

First, thank you so much for this incredible bit of software! My problem seems minor compared to everything that it does.

Okay, this is what I am running into. I recently had to do a re-install (Ubuntu 18.04), so I am starting fresh and currently using (copy-pasted from Information):

Mylar Version: development
-- git build 9579a39c36d0165c74b95b44063d3692eb04943a.
Python Version : 2.7.15rc1
Language : en_US.UTF-8

On the main page, I have several series which show "None/?" under the Have column, but then show the correct number of issues on the series page along with all of the issues, marked as Skipped. If possible, I would prefer the main page to have the correct information, so I can tell at a glance which series are complete and which might be missing any issues, without having to go into the individual series. More a convenience thing, but I figured I would point this out just in case it isn't just me.

If I try to Refresh the series, to force an update for the main page, I get an error ("There was an error" in a red box), but in the log, it simply notes that there are no new issues and will correctly note how many there are. If I try Recheck Files, then I get I get an exception:

2019-01-12 06:07:16 INFO I have added 0 new issues for this series that were not present before.

2019-01-12 06:07:24 INFO there are 2 files.

2019-01-12 06:07:24 ERROR Uncaught exception: Traceback (most recent call last):
File "/opt/Mylar/mylar/", line 337, in new_run
old_run(*args, **kwargs)
File "/usr/lib/python2.7/", line 754, in run
self.__target(*self.__args, **self.__kwargs)
File "/opt/Mylar/mylar/", line 994, in forceRescan
just_the_digits = re.sub('[^0-9]', '', cla['SeriesVolume']).strip()
File "/usr/lib/python2.7/", line 155, in sub
return _compile(pattern, flags).sub(repl, string, count)
TypeError: expected string or buffer

This is always the same error, no matter which series I recheck. All of the files have been named Name ### (YYYY MM) by Comictagger so there really should not be any odd characters in any of the filenames anywhere, especially not in that many of them. (I read through as many of the other threads on uncaught exceptions as I could and most of those seemed to be errors involving unicode.)

Edit: Meant to mention, I have tried deleting a series and re-adding it, but that doesn't change anything. No help there.

If it helps, this has nothing to do with downloading or processing. The files are already in the folders. Mylar obviously knows they are there, since it can count them during the Refresh Series. It's just having serious problems parsing them for some reason.

If you can help out, that is awesome. If not, then I can deal and no worries.

Again, thank you for all of the hard work that you have already put into Mylar. Even if it never gets updated again, it's still genius.

Posts: 92
Joined: Fri Feb 03, 2017 3:59 pm

Re: Error on Recheck Files

Post by barbequesauce » Sat Jan 12, 2019 12:01 pm

Evilhero has been reworking a lot of the file searching/post processing functionality as well as the CV interface to get TPB/GN support working. There’s been a bunch of commits posted since the one you’re running, and this issue quite possibly might have been fixed through a combination of them (although this is the first time I’ve seen it come up in this way).

So - check your config.ini and make sure alt_pull= 2; if it doesn’t, shut Mylar down before opening & editing it, and then start back up again. Click “check for new version” and update; after that, go into each problem series page and first refresh comic, then recheck files. With any luck that fixes it...

Posts: 8
Joined: Fri Jun 10, 2016 10:07 am

Re: Error on Recheck Files

Post by musictrivianut » Sat Jan 12, 2019 3:14 pm

Okay, I will definitely do that. Thanks much for the info. Appreciate it.

Posts: 8
Joined: Fri Jun 10, 2016 10:07 am

Re: Error on Recheck Files

Post by musictrivianut » Sat Jan 12, 2019 3:23 pm

Yeah, I was 6 commits behind. Updated and the very first series I updated worked just fine, found all of the issues. I'm going to have to remember to do a weekly update check.

Thanks again!

Post Reply