Mylar not downloading

Post any problems / bugs / issues that are Mylar-related in here.
Post Reply
themole3001
Posts: 7
Joined: Tue Sep 26, 2017 8:12 pm

Mylar not downloading

Post by themole3001 » Mon Nov 26, 2018 10:40 am

Hi evilhero

I've been away from using Mylar for a while, just left it running in the background and not tinkering with it or updating it; I've recently updated it to the most recent release and found it's no longer downloading issues from my primary provider (dog) which I've set in the config file as first priority in the search order. I can manually search dog and find all of the most recent issues on my watchlist, however the Mylar software hasn't successfully processed a download in over a month, and the logs are saying "could not find ______ using dognzb" even when the issue is available.

Has there been any major change to the way that either Mylar is searching, or dog is indexing the issues, that has broken the automation somehow?

Thanks!

User avatar
evilhero
Site Admin
Posts: 2274
Joined: Sat Apr 20, 2013 3:43 pm
Contact:

Re: Mylar not downloading

Post by evilhero » Mon Nov 26, 2018 4:39 pm

You'd have to paste the debug log for any search so we could see what's happening exactly. As far as I'm aware, there's been no issues with snatching items from dog (aside from the API going offline for maintenance, etc) which would cause it to stop searching.

In the last month, tiered searching has been added. This is where if something has been on the Wanted list for longer than 2 weeks, it gets moved to a secondary tier where it only gets searched against RSS Feeds (as opposed to < 2 weeks where it does both API + RSS searches) when performing automated searches. To search against the API for these items on the 2nd Tier, you have to perform a manual search for the given issues.

themole3001
Posts: 7
Joined: Tue Sep 26, 2017 8:12 pm

Re: Mylar not downloading

Post by themole3001 » Wed Nov 28, 2018 3:03 pm

Y'know - that may be it; it's been saying "searching DogNZB (RSS)" in the logs, and not finding anything. Is it possible to switch this off or is this at the request of the site owners?

I'll post the log anyway, sorry for not including it at first - this is only a portion of it, it pretty much goes on in the same vein. The only remarkable thing I can see is that the year changes from 2018 (search) to 2017 (Could not find message), don't know if that's significant.

26-Nov-2018 12:58:20 - INFO :: mylar.NZB_SEARCH.481 : Thread-12 : Shhh be very quiet...I'm looking for Injustice 2 issue: 24 (2018) using nzbplanet(newznab) [RSS].
26-Nov-2018 12:58:36 - INFO :: mylar.search_init.366 : Thread-12 : Could not find Issue 24 of Injustice 2 (2017) using nzbplanet [rss]
26-Nov-2018 12:58:36 - INFO :: mylar.NZB_SEARCH.481 : Thread-12 : Shhh be very quiet...I'm looking for Injustice 2 issue: 24 (2018) using oznzb(newznab) [RSS].
26-Nov-2018 12:58:48 - INFO :: mylar.search_init.366 : Thread-12 : Could not find Issue 24 of Injustice 2 (2017) using oznzb [rss]
26-Nov-2018 12:58:48 - INFO :: mylar.NZB_SEARCH.481 : Thread-12 : Shhh be very quiet...I'm looking for Injustice 2 issue: 24 (2018) using Usenet Crawler(newznab) [RSS].
26-Nov-2018 12:59:00 - INFO :: mylar.search_init.366 : Thread-12 : Could not find Issue 24 of Injustice 2 (2017) using Usenet Crawler [rss]
26-Nov-2018 12:59:00 - INFO :: mylar.search_init.397 : Thread-12 : findit: {'status': False}
26-Nov-2018 12:59:00 - INFO :: mylar.search_init.401 : Thread-12 : Finished searching via :rss. Issue not found - status kept as Wanted.
26-Nov-2018 12:59:01 - INFO :: mylar.search_init.71 : Thread-12 : Issue Title given as : city killer
26-Nov-2018 12:59:01 - INFO :: mylar.search_init.170 : Thread-12 : search provider order is ['dognzb', 'public torrents', 'Experimental', 'newznab:nzbplanet', 'newznab:oznzb', 'newznab:Usenet Crawler']
26-Nov-2018 12:59:01 - INFO :: mylar.NZB_SEARCH.481 : Thread-12 : Shhh be very quiet...I'm looking for Injustice 2 issue: 23 (2018) using dognzb [RSS].
26-Nov-2018 12:59:14 - INFO :: mylar.search_init.366 : Thread-12 : Could not find Issue 23 of Injustice 2 (2017) using dognzb [rss]

User avatar
evilhero
Site Admin
Posts: 2274
Joined: Sat Apr 20, 2013 3:43 pm
Contact:

Re: Mylar not downloading

Post by evilhero » Thu Nov 29, 2018 9:04 pm

It wasn't requested by the site owners or anything like that. But if you leave Mylar running, there's no point in making API requests for backlog searches for something that just did the same thing for 6hrs earlier when any/all changes up to that point are recorded in the RSS feeds.

So if something did get pushed out after the initial API search, the remaining subsequent searches are just wasted API hits for the user. Users that have a large Wanted list (as an example) would complain about Mylar having to search thru every issue in the Wanted list using their API hits, especially for items that wouldn't be normally posted or have been on their list for an extended period of time with no results.

So the tiered search was a way to allow everyone to have their way - newer issues get searched normally for 2 weeks as that's well within the timeframe for weekly issues, and issues longer on the Wanted list still get polled against every RSS search incase someone uploads it well after the fact.

Now the year thing where it increments by one is actually normal - Mylar notices that the date for the issue is in Nov/Dec and then adjusts the search to accommodate items that might have the 2019 tag by mistake. In this case it didn't matter, but usually it happen moreso after the new year, when issues are dated as 2018 but it's searching in 2019.

And as far as the logs, unfortunately INFO level logs aren't that much help as it's really not for troubleshooting scenarios like this. If you could enable debug/verbose logging, and then try another search for one issue - and then paste that debug log in here, it will be filled with all sorts of information that might help out figuring what's happening.

themole3001
Posts: 7
Joined: Tue Sep 26, 2017 8:12 pm

Re: Mylar not downloading

Post by themole3001 » Mon Dec 03, 2018 2:49 pm

OK, so there was an update notification when I went in to check the logs for the required info. I ran the update, and enabled verbose logging after the restart had completed. Searched for an issue which I knew was on Dog and wasn't downloading... and it downloaded. So have the further four I've tried. So not sure if you addressed the issue in the last update or if it's just coincidence. Either way I'm happy enough to go through the individual series' and manually search for the missing issues from the last couple of months, and keep an eye on it in the future.

Thanks for your patience and the explanation - that makes total sense (even to an outsider like myself).

Post Reply