Config settings not being honored

Post any problems / bugs / issues that are Mylar-related in here.
Post Reply
lnlytrll
Posts: 5
Joined: Tue Nov 17, 2015 3:47 pm

Config settings not being honored

Post by lnlytrll » Thu Sep 06, 2018 8:25 pm

So, I'm coming at this because I can't get Mylar to load through my reverse proxy on NGINX, but I think my configuration is correct there, and everything will work once I get Mylar to do what it should be doing.

Mylar Version: b69f132fd76c04e129897495be2d453e520e804a (development)
OS: Raspbian 9 (stretch)

I have the following in my config.ini file:

Code: Select all

[Interface]
http_password = None
https_chain = None
authentication = 0
http_port = 8090
login_timeout = 43800
http_root = /mylar
web_root = /mylar
https_force_on = False
https_cert = None
http_host = 0.0.0.0
enable_https = False
https_key = None
host_return = None
http_username = None
However, when I load localhost:8090 in the browser, I am presented with "http://localhost:8090/home" as the address, rather than "http://localhost:8090/mylar/home" which I would expect.

In researching what is going on, I noticed I also have the following:

Code: Select all

[General]
...
launch_browser = True
This is shown as a checked box in the config, but the browser DOES NOT launch when I restart the Mylar service (sudo service mylar restart) I have installed. I am using the standard Ubunto.init.d that came with the clone.

Any ideas why this isn't working as it should?

barbequesauce
Posts: 14
Joined: Fri Feb 03, 2017 3:59 pm

Re: Config settings not being honored

Post by barbequesauce » Thu Sep 06, 2018 8:33 pm

Silly question - are you sure you're using the right config file?

On the first tab of the Config screen you'll see a list of files & locations - the last one is the active config file. Is that the one you're updating?

Assuming it is, you can click on that filename and you will get a list of all the variables in memory. You can use the search box on the top right to see the individual entries. What is http_root set to there?

lnlytrll
Posts: 5
Joined: Tue Nov 17, 2015 3:47 pm

Re: Config settings not being honored

Post by lnlytrll » Thu Sep 06, 2018 8:45 pm

That was 100% the problem. I was looking in /opt/Mylar, where the install guide had me clone the repo.

Thanks!

Post Reply