Settings - Permissions

Post any problems / bugs / issues that are Mylar-related in here.
Post Reply
Aimhere
Posts: 95
Joined: Mon Apr 06, 2015 2:32 pm

Settings - Permissions

Post by Aimhere » Mon May 21, 2018 4:18 pm

Hi,

I have Mylar set to enforce permissions on files and directories. I recently tried to change the permissions values on the Settings/Web Interface/Permissions section, and after I clicked Save, I could confirm that the new values had been written to the config.ini file. However, when I reload the Settings page (even after shutting down and restarting Mylar), Mylar reverts to the OLD (default?) values. I will BRIEFLY see my new values in the input boxes on the form, then they change back to the old values before my eyes, and remain at those values even after further refreshing of the page. And, if I were to click Save while Mylar is in this state, those old values get written back to config.ini.

I've tried clearing my browser's cache, using different browsers (Firefox, Chrome, Edge)... in every case, the permissions values keep reverting.

Any idea why this is happening?

aimhere

(P.S. - Mylar, latest development version, on Synology DSM 6.1)

capGrundy
Posts: 44
Joined: Thu Nov 09, 2017 12:25 am

Re: Settings - Permissions

Post by capGrundy » Thu May 24, 2018 2:02 pm

I have slightly similar experience that may be unrelated. I can get the permissions to work fine, but it doesn't seem to be able to communicate the user/group. I've tried the name and uid/gid, but it either ignores it, or replaces it with something like an "abc123" placeholder name.

It's not a big deal, because I can get things ok with chmod, but I wasn't sure if it was a bread crumb along the same lines or not.

User avatar
evilhero
Site Admin
Posts: 2216
Joined: Sat Apr 20, 2013 3:43 pm
Contact:

Re: Settings - Permissions

Post by evilhero » Thu May 24, 2018 2:21 pm

@Aimhere : Are you still running the hybrid-frankenstein install of Mylar? (like the synopkg /git combo or whatever it was that you were doing at the time - I remember the previous posts you made mention of it)

It sounds like your synology is enforcing the perms to some degree, and/or your config.ini file is not the correct one (ie. you're viewing it at one location, but it's being written to another location). Given your previous posts about the synology stuff, this might be what's occuring. You can see the config file where Mylar is loading it from is in the 1st tab of the Mylar Configuration. If it's a different location than what you were looking at, then it's the wrong file location. I would also check the perms on the config.ini to make sure the user running Mylar has the proper permissions (again synology likes to enforce stuff on their end, so not quite sure if it's just as simple as doing a 'ls -l' kinda thing).

@capGrundy: the user running Mylar has to be able to perform the chmod/chown command (since that's basically what it's doing), so it has to have the right permissions to do so in the given directory (at least prior to the first chmod/chown). If you're running Mylar as the user as part of a group, it migth not be able to chown as that's an ownership flag and I'm not 100% sure if being in a group is considered high-enough permissions to change the ownership of the given file (I just can't remember atm)

Post Reply