Git Issue

Post any problems / bugs / issues that are Mylar-related in here.
Post Reply
leaderdog
Posts: 218
Joined: Sun Apr 26, 2015 1:52 pm

Git Issue

Post by leaderdog » Wed May 02, 2018 12:18 pm

Hi Evilhero,

I tried to add the latest 5 updates.

I did what I always do:

1) kill instance of python running in windows
2) use cmd and navigate to c:\Mylar
3) git pull

This time it gave an error:
"please, commit your changes or stash them before you can merge."

I backed up all files in Mylar before proceeding:

1) After googling I reset the head or something like that, but I don't think it did anything.
2) restored my files
3) I ran cmd with elevated privileges and it read the above error.

I'm not sure what to do to get it to merge the files.

Windows 7 machine

Thanks

User avatar
evilhero
Site Admin
Posts: 2258
Joined: Sat Apr 20, 2013 3:43 pm
Contact:

Re: Git Issue

Post by evilhero » Wed May 02, 2018 12:25 pm

Looks like you have local changes done, so it can't overwrite the files to merge the commits.

You can see what the changes are by doing a :

Code: Select all

git status |more
It will show you the exact files that are different and basically stopping the merge.

If you don't have any local changes, or don't care about saving them (ie. You didn't modify any files for a particular reason), then you can do:

Code: Select all

git fetch --all
git reset --hard origin/development

Note that if you're on master branch, you want to change development to master in the reset command above.

leaderdog
Posts: 218
Joined: Sun Apr 26, 2015 1:52 pm

Re: Git Issue

Post by leaderdog » Wed May 02, 2018 12:31 pm

Hi Evilhero

I think we tried adding some commands for experimental to look at alt.dcp.reposts or something like that.

ok did as you said.

it says:

HEAD is now at 47b4757 FIX: callback value was not set on secondary dupecheck pass

and git pull again says already-up-to-date.

So I'll assume it worked.

Thanks :)

Post Reply