Post-processing with ComicRN failing

Post any problems / bugs / issues that are Mylar-related in here.
Rumik
Posts: 17
Joined: Sat Jul 22, 2017 12:21 pm

Re: Post-processing with ComicRN failing

Post by Rumik » Mon Jun 04, 2018 4:17 pm

I mean NZBget’s script directory. Everything was fine until a few months ago and I haven’t changed anything other than update Mylar whenever a new version is available.

Mylar is definitely set to 0.0.0.0:8090 and the api is definitely correct.

I don’t see anything in Mylar’s debug logs about the localhost url tho, even though NZBGet is receiving the download. Everything downloads fine, it’s just ComicRN fails so the sorting doesn’t happen.

User avatar
evilhero
Site Admin
Posts: 2216
Joined: Sat Apr 20, 2013 3:43 pm
Contact:

Re: Post-processing with ComicRN failing

Post by evilhero » Mon Jun 04, 2018 4:26 pm

What do you have your host set to in the autoProcessComics.cfg file ?

Rumik
Posts: 17
Joined: Sat Jul 22, 2017 12:21 pm

Re: Post-processing with ComicRN failing

Post by Rumik » Mon Jun 04, 2018 4:33 pm

The host is set to 0.0.0.0, port 8090.

I’ve made some progress. Even though Mylar’s web interface settings have it set to port 8090 I access it’s front end on port 48090. Changing the connection port in autoProcessComics.cfg to 48090 results in the script not failing... but it is now stalling like it was before. NZBGet just sits there on “executing post-process-script ComicRN.py”

If I let the post process stay there running ComicRN for a while cancelling it results in the correct sorting of the file into the right folder. But the script never successfully finishes on its own, it just holds up the rest of the queue. That’s the problem I was trying to solve in the first place :p

User avatar
evilhero
Site Admin
Posts: 2216
Joined: Sat Apr 20, 2013 3:43 pm
Contact:

Re: Post-processing with ComicRN failing

Post by evilhero » Mon Jun 04, 2018 4:43 pm

Ok, so now I'm confused abit about the setup.

Mylar is listening on port 8090, but you're port-forwarding on 48090? Where is the forwarding taking place - on the router, nginx/apache, etc ?

The only way port 48090 would matter is if you're external to the Mylar instance - otherwise it listens on the localhost on port 8090 for incoming connections.

So what it sounds like at this point, is that you need to set the host value in the autoProcessComics.cfg file to your IP address (ie. do not use localhost, or even 0.0.0.0) - it can't resolve localhost properly from the looks of it for some reason.

User avatar
evilhero
Site Admin
Posts: 2216
Joined: Sat Apr 20, 2013 3:43 pm
Contact:

Re: Post-processing with ComicRN failing

Post by evilhero » Mon Jun 04, 2018 4:45 pm

Do you have Completed Download Handling enabled for NZBGet within Mylar ?

jedimole
Posts: 88
Joined: Sat Jan 02, 2016 9:19 pm

Re: Post-processing with ComicRN failing

Post by jedimole » Tue Jun 05, 2018 5:08 pm

Is there sample of the cfg file someplace? Im not sure where the or what the proper syntax is for the apt key?

User avatar
evilhero
Site Admin
Posts: 2216
Joined: Sat Apr 20, 2013 3:43 pm
Contact:

Re: Post-processing with ComicRN failing

Post by evilhero » Tue Jun 05, 2018 5:30 pm

sample.config

Code: Select all

[Mylar]
host=localhost
port=8090
apikey=
web_root=
ssl=0

jedimole
Posts: 88
Joined: Sat Jan 02, 2016 9:19 pm

Re: Post-processing with ComicRN failing :SOLVED

Post by jedimole » Tue Jun 05, 2018 5:40 pm

Ok, I finally got mine all solved and its working from withing NZBget script directory!

The issue was with my config file, and it all stemmed from not having the latest\edited file located in C:\ProgramData\NZBGet\scripts directory. I found the proper syntax for the API location in GitHub and added the API key from the mylar settings.

So now NZBget does the rename and does the pushbullet piece all from NZB. I still have mylar do a scheduled post process in case I pull one-offs from dog\nzbget outside of mylar (which is rare but only happens if mylar doesn't find a comic due to some funky issue.

Everything is all good ATM! If anyone needs help shoot a message here. Maybe I'll make a post with screenies of how I have my setup. Just hate the fact I cant post pictures into the messages.

Rumik
Posts: 17
Joined: Sat Jul 22, 2017 12:21 pm

Re: Post-processing with ComicRN failing

Post by Rumik » Sun Jun 10, 2018 12:45 pm

Sorry for the delay in replying, I've been away.

Haven't got much further than this. My .cfg is now pointing to the ip address of the server on port 48090, and I've set Mylar's web port to 48090 (for some reason connecting on 8090 just wasn't working). ComicRN runs, but it stalls still, holdingup the rest of the NZBget queue. The log just says it's running and then nothing else. Manually cancelling it once it's been running for a minute does result in it being correctly sorted into its folder.

That's where I am!

Thanks

User avatar
evilhero
Site Admin
Posts: 2216
Joined: Sat Apr 20, 2013 3:43 pm
Contact:

Re: Post-processing with ComicRN failing

Post by evilhero » Sun Jun 10, 2018 2:16 pm

Do you have completed download handling enabled for nzbget within Mylar?

Post Reply