Problem with Docker instances of Mylar & sabnzbd

Post any problems / bugs / issues that are Mylar-related in here.
Post Reply
Posts: 2
Joined: Fri Dec 07, 2018 10:32 am

Problem with Docker instances of Mylar & sabnzbd

Post by Cantello » Fri Dec 07, 2018 11:09 am

First of all - thanks for creating this app and even helping out with problems here! :-D

I am trying to dockerize my download setup and ran into a problem with Mylar: it does not seem to import downloaded files from the download directory into the comics folder. Post-processing is enabled ('move') and the script is also running.

Sabnzbd's output when running ComicsRN is:

Code: Select all

Requests module not found on system. I'll revert so this will work, but you probably should install
requests to bypass this in the future (ie. pip install requests)
Loading config from /config/scripts/autoProcessComics.cfg
Opening URL:
nzb name: Rick.and.Morty.008.2015.Digital.AnHeroGold-Empire
nzb folder: /downloads/Rick.and.Morty.008.2015.Digital.AnHeroGold-Empire
nzbname: Rick.and.Morty.008.2015.Digital.AnHeroGold-Empire
Issue Year: 2015
Publisher: Oni Press
Series: Rick and Morty
Year: 2015
Comic Location: /comics/Rick and Morty (2015)
Comic Version: None
No version # found for series - tag will not be available for renaming.
Original Filename: Rick.and.Morty.008.2015.Digital.AnHeroGold-Empire.cbz [.cbz]
New Filename: Rick and Morty 8 (2015)
Destination:/comics/Rick and Morty (2015)/Rick and Morty 8 (2015).cbz
[move] /downloads/Rick.and.Morty.008.2015.Digital.AnHeroGold-Empire/Rick.and.Morty.008.2015.Digital.AnHeroGold-Empire.cbz - to - /comics/Rick and Morty (2015)/Rick and Morty 8 (2015).cbz
Removed temporary directory : /downloads/Rick.and.Morty.008.2015.Digital.AnHeroGold-Empire
Post Processing SUCCESSFUL!
Problem is: the script does not move the renamed file into the specified folder (/comics/Rick & Morty (2015)). It does not matter if the folder exists or not or if permissions are set correctly or not (had them wrong at first so that docker user was unable to write). This makes me suspicious if the folder the script is referring to is even the same as the one I am expecting (docker folder binding etc.) but if I check folders from within sabnzbd with the folder selector, "/comics" goes to the correct folder and the script is executed by sabnzbd so sab's folder bindings should be the ones that are relevant.

Mylar's logs:

Version info:
Mylar Version: master
-- git build 34e540c75f06b773e5c8f0c0605345e3911f48c7. Python Version : 2.7.15

Any ideas what I could be doing wrong? Can the options in Mylar/Post-Processing be relevant for this? Tried different combinations but to no avail.

Posts: 2
Joined: Fri Dec 07, 2018 10:32 am

Re: Problem with Docker instances of Mylar & sabnzbd

Post by Cantello » Fri Dec 07, 2018 2:09 pm

Sorry, was my bad. Docker problems as I suspected. The config file in OpenMediaVault (where I run Docker) showed the correct path but actually a different path was used when I remembered to just use updatedb/locate to search for the 'missing' files.

Everything is now as it should be - or at least will be once I figure out the configuration. :-)

Post Reply