Log page messed up

Post any problems / bugs / issues that are Mylar-related in here.
Post Reply
Aimhere
Posts: 95
Joined: Mon Apr 06, 2015 2:32 pm

Log page messed up

Post by Aimhere » Sun May 20, 2018 3:21 pm

Hi,

I recently went to check the logs page in Mylar right after restarting it, and found the page wasn't displaying ANY information from the log. There was just the line "Showing 59,026 to 22 of 22 lines".

I tried clearing the log from the web page, as well as shutting down and restarting Mylar again. But i still can't get the log page to show anything. How can I clear this up?

I will note that I can view the logs from a terminal shell, and they appear to show the usual Mylar startup sequence.

Running Mylar development 4314b8b98cc25d6ed54313b611e638ab63711b4e on Synology DSM 6.1.6.

aimhere

User avatar
evilhero
Site Admin
Posts: 2263
Joined: Sat Apr 20, 2013 3:43 pm
Contact:

Re: Log page messed up

Post by evilhero » Sun May 20, 2018 3:54 pm

Usually that happens when the filter is active - check to make sure you don't have a space in the filter box on the logs page, as it will assume that as a filter and perform a filter based upon that.

Aimhere
Posts: 95
Joined: Mon Apr 06, 2015 2:32 pm

Re: Log page messed up

Post by Aimhere » Sun May 20, 2018 5:06 pm

Nope, no space (or anything else) in the Filter box.

It's weird that the page says something like "Showing 59,026 to 22 of 22 lines" when there are only 22 lines IN the log. (And yes, the log file on disk really has only 22 lines in it.) Where does it get the count of "59,026" from?

aimhere

User avatar
evilhero
Site Admin
Posts: 2263
Joined: Sat Apr 20, 2013 3:43 pm
Contact:

Re: Log page messed up

Post by evilhero » Sun May 20, 2018 5:11 pm

That's usually what happens - the rest is probably from memory that it won't release for some reason.

Have you tried restarting Mylar? That should force the memory to get dumped and the logs should return to normal.

Aimhere
Posts: 95
Joined: Mon Apr 06, 2015 2:32 pm

Re: Log page messed up

Post by Aimhere » Sun May 20, 2018 5:41 pm

Yes, I shut it down and restarted it. Several times. The log page still stubbornly says something like "Showing 59,026 to 4,578 of 4,578 lines".

Aimhere
Posts: 95
Joined: Mon Apr 06, 2015 2:32 pm

Re: Log page messed up

Post by Aimhere » Mon May 21, 2018 4:20 am

I left Mylar alone most of the day, and the problem finally seems to have corrected itself once the logs on disk grew large enough.

Post Reply