Changing comictagger settings

Information and Tutorials on features in Mylar and how to use it
Post Reply
stustap
Posts: 2
Joined: Fri Nov 10, 2017 8:13 pm

Changing comictagger settings

Post by stustap » Fri Nov 10, 2017 8:23 pm

Firstly, I just wanted to say a huge thank you to evilhero for this software - I have been using it for years at this point and it is fantastic.

I've only recently started to meddle with the post processing to save me having to do it all manually in Comicrack and I seem to have it all working smoothly. The only niggle I'm having is that comictagger uses sequential numbering for the comic volume, whereas my entire library tagged through comicrack uses the year the volume started as the volume number.

From digging around it seems that comictagger allows for either option, but I can't figure out how to change the setting. I have tried manually amending the settins.ini file found in '/Mylar/lib/comictaggerlib/ct_settings' to include the following code:

Code: Select all

[comicvine]
use_series_start_as_volume = True
But this doesn't work, and in fact gets removed from the settings.ini file whenever post-processing is run.

Am I looking in the correct place? Any help is greatly appreciated.

I should mention I'm running Mylar on a QNAP NAS.

User avatar
evilhero
Site Admin
Posts: 2027
Joined: Sat Apr 20, 2013 3:43 pm
Contact:

Re: Changing comictagger settings

Post by evilhero » Fri Nov 10, 2017 9:17 pm

You almost got it!

Because the comictagger that's included with Mylar has been modified to work just with Mylar, the ct_settings.ini file only works for certain key variables that aren't exposed outside of comictagger. The setting you're looking for is actually in the config.ini of Mylar itself and there are 2 fields you need to enable.

The first is the cmtag_volumefield and it should be set to 1 to enable (cmtag_volume=1). Enabling this field tells mylar to use the volume tag when metaggging. How it's used however is what the second setting enforces.

The second is the cmtag_start_year_as_volume field and it should be set to 1 to enable. (cmtag_start_year_as_volume=1). Setting this to True tells Mylar to use the start year as the volume. Leaving this as 0 (disabled) however, will tell Mylar to use the volume numbering (if available).

Make sure Mylar isn't running when you edit the config.ini, and then you should be good from that point ;)

stustap
Posts: 2
Joined: Fri Nov 10, 2017 8:13 pm

Re: Changing comictagger settings

Post by stustap » Fri Nov 10, 2017 10:01 pm

Amazing - thank you that worked perfectly! I didn't think to look in the general config section.

Just one other question - comictagger doesn't seem to scrape the 'Released Date' by default, is there a way to enable this?

User avatar
evilhero
Site Admin
Posts: 2027
Joined: Sat Apr 20, 2013 3:43 pm
Contact:

Re: Changing comictagger settings

Post by evilhero » Sat Nov 11, 2017 1:22 am

Actually it does - but probably not in the format that you're wanting/expecting:

- with ComicRack tagging (in ComicInfo.xml) - it stores it in 3 separate fields: Year, Month, and Day.
- with ComicBookLover tagging (in zip comments) - it stores it in 2 separate fields: publicationYear, and publicationMonth

It might be that however you're viewing it (via a reader), might not read those values properly.

Now, it might be possible to create a custom field so when Mylar performs the metatagging it can be poplulated all in one field (ie.YYYY-MM-DD), but again - if the reader doesn't support the custom fields it's not going to matter much.

And these custom fields would only apply to ComicRack Tagging, not comicbooklover tagging (I don't think it supports custom fields, but it could be wrong).

Post Reply